General issues or errors for running Kindle Mate

Viewed 899 Times 0 Comments

Kindles and OS Compatibility

  • All Kindles including Kindle 1/2/3/DX/Keyboard/Touch/Paperwhite/Voyage/Kindle Oasis
    Kindle for PC/Mac, Kindle App for iOS/Android currently NOT supported. 
  • Windows XP/Vista/7/8/8.1/10 requires .NET Framework 4.0 CP (download), VC++ Runtime Library(download)
  • Kindle Mate for Mac (Mac OS X, macOS) currently not supported but has been planned to release soon.

Issues or errors and what to do

First of all, try installing Kindle Mate Full Installer first, which may simply solve 99% of your issues.

  • Could not load file or assembly ‘System.Data.SQLite’  one of its dependencies, install VC++ Runtime Library(download) and then run Kindle Mate again.
  • .NET Framework related errors, install .NET Framework 4.0 CP (download) first.
    Typically you are running old Windows XP, since .NET Framework 4.0 and above is built in by default  in most up-to-date Windows systems.
  • File Access or privilege related error:  install Kindle Mate to user folders instead of Program Files or other system folders.
    Kindle Mate has changed its default UAC requirement since 1.35, which no longer requires Administrator role to run Kindle Mate. Thus currently the default install folder is My DococumentsKindle Mate for the best advantages.
Was this answer helpful ? Yes (5) / No (0)

Leave a Reply

Your email address will not be published. Required fields are marked *